Marcar un paquete para que nunca se actualice en Linux (Debian y derivadas)

Muchas veces puede pasar que tengas una cierta aplicación que no quieras que se actualice. Ya sea porque las nuevas versiones te han dado problemas de compatibilidad con tu sistema, no funcionan, eliminan componentes o funciones que te resultaban útiles o simplemente te sientes cómodo con su funcionamiento actual. Por ejemplo, en mi caso utilizo la versión 5.7 de Lutris y no las posteriores debido a que hay características que me gustan y no me funcionan del todo bien en versiones posteriores.

Para marcar un paquete como «no actulizable» existe el comando apt -mark hold. Funciona de la siguente manera: sudo apt-mark hold nombre del paquete

Si quisiéramos marcar Lutris, luego de instalar el paquete Lutris 5.7 ejecutaría el siguiente comando: sudo apt-mark hold lutris

Luego, para verificar que el paquete fue retenido y no se actualizará, podemos usar el siguiente comando (nos mostrará todos los paquetes marcados para retener): apt-mark showhold

Finalmente, si deseamos desmarcar el paquete y que se actualice con el sistema, utilizamos el siguiente comando: sudo apt-mark unhold lutris

Espero sea de utilidad la herramienta y no duden en probarla.

Comentarios

Deja un comentario